END of PHP 5.6 and no support by the community.

END of PHP 5.6 and no support by the community.

Which version of PHP is compatible with my PrestaShop store?

First of all, it is essential to ensure that the version of your PrestaShop store is compatible with the latest versions of PHP. This will let you avoid updating errors and random behavior (for example, problems while updating modules, product sheets, etc.). We recommend that you trial the new version in a test environment before using it.

PrestaShop x PHP compatibility

PrestaShop versionsCompatible PHP versions
1.5.x ~ 1.6.05.2 – 5.5
1.6.1.x5.2 – 7.1
1.7.0 ~ 1.7.35.4 – 7.1
1.7.45.6 – 7.1
1.7.55.6 – 7.2

Please note: a PrestaShop store always comprises a version of the PrestaShop software program and a number of modules that have been added to the store. The modules must also be compatible with the PHP version that you are running.

source from https://www.prestashop.com/en/blog/php-5-6-online-store-security



Start typing and press Enter to search